Absa intermitted performance
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Nov 25, 2021 - 15:45 SAST
Investigating
Investigating - We are monitoring Absa customer bank transactions due to intermitted authentication
Posted Nov 25, 2021 - 13:51 SAST
This incident affected: Third-party Platforms (Issuing systems for Card processing).