Tymebank intermitted performance
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Jun 24, 2022 - 18:28 SAST
Investigating
As per feedback from Visa, Tyme Bank experiencing issues and is currently investigating.
No ETR has been provided.
Posted Jun 24, 2022 - 16:40 SAST
This incident affected: Third-party Platforms (Issuing systems for Card processing).