Peach Payments Payouts - intermitted
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted May 19, 2022 - 09:47 SAST
Investigating
We have been informed by our Payouts partner and our banking partner that the payouts functionality is not being actioned.
Our team are currently working on identifying the issue and solving it.
Please bear with us.
Posted May 18, 2022 - 10:27 SAST
This incident affected: Third-party Platforms (Payouts).