FNB intermittent downtime for cardholders
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Jul 01, 2022 - 18:00 SAST
Investigating
FNB have confirmed, that they are aware of an issue with their digital channels:
See below response from FNB via Twitter:
We sincerely apologise for the limited functionality on our digital channels. Our IT teams are working hard to urgently restore full functionality on the affected channels. Thank you for your patience.
Posted Jul 01, 2022 - 13:11 SAST
This incident affected: Third-party Platforms (Issuing systems for Card processing).