Masterpasss - intermittent performance
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Jun 17, 2022 - 10:18 SAST
Monitoring
Update - Masterpass Service recovered

The technical support team is currently investigating further to establish the cause.

We do apologize for the inconvenience caused.
Posted Jun 10, 2022 - 15:27 SAST
Investigating
Please note, we are currently investigating issues affecting the Masterpass service from Masterpass.

Our technical teams are busy investigating and working to resolve the issue as soon as possible.

Resolution time is unknown at this time.
Posted Jun 10, 2022 - 10:30 SAST
This incident affected: Third-party Platforms (Scan to Pay (Masterpass)).