FNB Acquiring processing intermitted performance
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Jun 25, 2022 - 13:53 SAST
Investigating
We are currently investigating this issue.
Posted Jun 25, 2022 - 12:00 SAST
This incident affected: Third-party Platforms (FNB card acquiring).