FNB merchant transacting unavailable
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Jun 20, 2022 - 21:32 SAST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 20, 2022 - 18:13 SAST
Investigating
We are currently investigating an incident with FNB where all transactions on FNB merchant accounts are failing this is only impact card transactions; shoppers can still use alternative payment methods
Posted Jun 20, 2022 - 08:57 SAST
This incident affected: Third-party Platforms (FNB card acquiring).