Absa acquiring intermitted performance
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Jun 25, 2022 - 13:53 SAST
Update
We continue to investigate Bankserv is unreachable.
Case logged with the acquirer and Bankserv.
Posted Jun 25, 2022 - 11:44 SAST
Investigating
We are currently investigating this issue.
Posted Jun 25, 2022 - 10:58 SAST
This incident affected: Peach card processing platform and Third-party Platforms (Absa card acquiring).