FNB 3DS intermittent downtime for cardholders
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Dec 07, 2021 - 16:13 SAST
Investigating
Higher than usual unsuccessful transactions for FNB cardholders. FNB 3DS is experiencing intermittent breaks and thus resulting in card transactions for these card holder to be unsuccessful
Posted Dec 07, 2021 - 13:45 SAST
This incident affected: Third-party Platforms (Issuing systems for Card processing).