Standard Bank duplicate transaction
Incident Report for Peach Payments
Resolved
Standard Bank duplicate transaction
We have raised this is Nedbank acquiring and Standard bank card issuing who are currently investigating the duplicate transactions being seen on Customers' statements.
Standard Bank and Nedbank are working on a solution.
At this time, we do not have any timelines.
Cardholders must be referred to a Standard bank.
Posted May 13, 2022 - 12:16 SAST
Investigating
We have raised this is Nedbank acquiring and Standard bank card issuing who are currently investigating the duplicate transactions being seen on Customers' statements.
Standard Bank and Nedbank are working on a solution.
At this time, we do not have any timelines.
Cardholders must be referred to standard bank.
Posted May 13, 2022 - 12:15 SAST
This incident affected: Third-party Platforms (Issuing systems for Card processing, Nedbank card acquiring).