Absa EFT - disabled due to technical
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Aug 15, 2022 - 08:03 SAST
Investigating
Please note: ABSA is currently disabled on our Eftsecure services due to Technical issues on their banking Portal.
Posted Aug 11, 2022 - 17:12 SAST
This incident affected: Third-party Platforms (EFT Secure).