Standard Bank customers - Banking App and Internet Banking
Incident Report for Peach Payments
Resolved
Standard Bank team update - Banking App and Internet Banking
Incident resolved
Earlier today Standard Bank experienced technical issues on its Banking App and Internet Banking application. These services have been restored, and customers can now access and use Internet Banking and the Mobile App.
Our technicians worked tirelessly to restore services to these banking channels. Regrettably, efforts to restore these services to their full functionality took longer than expected. For this we sincerely apologise. No other banking channels were impacted.
Posted Dec 09, 2021 - 17:06 SAST
Investigating
Standard Bank is Investigating - We are aware that you may be experiencing difficulties logging on to some of our digital channels. Our technical teams are working to resolve the issue as soon as possible. Please dial *120*2345#on your mobile phone for Cellphone Banking. We apologise for the inconvenience caused.
Posted Dec 09, 2021 - 12:01 SAST
This incident affected: Third-party Platforms (Issuing systems for Card processing).