Investigating - ABSA bank is currently under maintenance and are disabled on EFT Secure.

Please reach out to support@peachpayments.com with any questions or concerns.

Mar 27, 2024 - 08:32 SAST
Investigating - We are seeing iOS/Safari issues where Nedbank Direct EFT is not loading in i-frames - we are working with our Nedbank partners to remedy this problem as soon as possible
Mar 14, 2024 - 10:47 SAST
Identified - Dear Merchant,

Capitec recently launched Capitec Pay, enabling customers to checkout quickly and securely through the Capitec app. This replaces the Capitec Bank option on our EFT solutions.

To continue processing Capitec payments, please reach out to us via support@peachpayments.com or your Peach Payments account manager to have this exciting new payment method enabled on your account.

Apr 01, 2023 - 00:00 SAST

About This Site

Welcome to Peach Payment's real-time and historical data on system performance, which includes payment processing performance.
Kindly note that we will only send notifications for incidents that have been verified (internally or with a partner or third party) therefore time needs to allow for this verification to occur, which may result in a delay in updating.

Peach card processing platform Operational
90 days ago
99.71 % uptime
Today
Checkout Operational
90 days ago
100.0 % uptime
Today
Plugins and Platforms Operational
90 days ago
100.0 % uptime
Today
Magento Operational
90 days ago
100.0 % uptime
Today
WooCommerce Operational
90 days ago
100.0 % uptime
Today
PaySafe Operational
90 days ago
100.0 % uptime
Today
Shopify Operational
90 days ago
100.0 % uptime
Today
Payment API Operational
90 days ago
100.0 % uptime
Today
Wix Operational
90 days ago
100.0 % uptime
Today
Payment Links Operational
90 days ago
100.0 % uptime
Today
PaySafe Operational
90 days ago
100.0 % uptime
Today
Support Operational
90 days ago
100.0 % uptime
Today
Console ? Operational
90 days ago
100.0 % uptime
Today
Card portal (BIP) ? Operational
90 days ago
100.0 % uptime
Today
Phone Support Operational
90 days ago
100.0 % uptime
Today
Freshdesk Peach Payments Support email Operational
90 days ago
100.0 % uptime
Today
Dashboard - Peach Payments Operational
90 days ago
100.0 % uptime
Today
Third-party Platforms ? Degraded Performance
90 days ago
99.98 % uptime
Today
1Voucher Operational
A+ Operational
Absa card acquiring ? Operational
ApplePay Operational
Capitec Pay Operational
90 days ago
99.82 % uptime
Today
EFT Secure Operational
Equity Bank Kenya Operational
90 days ago
100.0 % uptime
Today
Debit Orders Operational
90 days ago
100.0 % uptime
Today
FNB card acquiring Operational
I&M Bank Acquiring - Kenya Operational
90 days ago
100.0 % uptime
Today
Instant EFT by Peach Payments Operational
90 days ago
100.0 % uptime
Today
Issuing systems for Card processing ? Operational
Peach card acquiring Operational
Nedbank card acquiring Operational
Scan to Pay (Masterpass) Operational
MCB Bank Mauritius Operational
90 days ago
100.0 % uptime
Today
Mobicred Operational
MPESA Operational
Payflex Operational
90 days ago
100.0 % uptime
Today
PayPal Operational
90 days ago
100.0 % uptime
Today
Payouts Operational
90 days ago
100.0 % uptime
Today
Planet Payments Multi Currency Payments Operational
90 days ago
100.0 % uptime
Today
Tyme bank card Operational
90 days ago
100.0 % uptime
Today
FinChoice Operational
90 days ago
100.0 % uptime
Today
Nedbank Direct EFT Degraded Performance
90 days ago
100.0 % uptime
Today
Peach Payments Plugin or API Update Notifications ? Operational
90 days ago
100.0 % uptime
Today
Peach WooCommerce Plugin Update ? Operational
Peach Magento Plugin Update ? Operational
Peach Copy and Pay API ? Operational
Peach Server to Server API ? Operational
Peach Mobile SDK Updates and Changes ? Operational
Peach NopCommerce Plugin Updates ? Operational
Peach OpenCart Plugin Updates ? Operational
Peach Shopify Plugin Updates ? Operational
Peach Custom Host Checkout Redirect API Updates ? Operational
Peach Wix Plugin Updates ? Operational
PaySafe Update ? Operational
Payments API Custom Integration Update Operational
90 days ago
100.0 % uptime
Today
MSDK Updates Operational
90 days ago
100.0 % uptime
Today
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Scheduled Maintenance
Capitec App Planned Maintenance Apr 1, 2024 01:00-02:00 SAST
Capitec is planning maintenance on their App.

Intermittent downtime on the 1st of April from 01:00 am – 02:00 am.

Here is what we know so far:
Impacted systems - All Capitec Pay Transactions will be affected on the App.
Impact on the client - The clients will not be able to log into the App to approve the transaction.

Please reach out to support@peachpayments.com with any questions or concerns.

Posted on Mar 28, 2024 - 18:00 SAST
Past Incidents
Mar 28, 2024
Completed - The scheduled maintenance has been completed.
Mar 28, 09:00 SAST
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 28, 05:00 SAST
Scheduled - Thursday, 28th March 5am-9am SAST

During this period ABSA will be doing maintenance on 2 of their payon servers

There will be no impact to live transaction processing as all transactions will be automatically routed through the other 2 servers.

Please reach out to support@peachpayments.com with any questions or concerns

Mar 26, 08:50 SAST
Mar 27, 2024
Resolved - This incident has been resolved.
Mar 27, 08:31 SAST
Investigating - Please note: ABSA is currently disabled on our Eftsecure services due to Technical issues on their banking Portal.
Notice: We acknowledge ongoing issues with ABSA on EFTsecure. Our engineering team is actively investigating the matter.

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.

Feb 27, 09:17 SAST
Completed - The scheduled maintenance has been completed.
Mar 27, 05:00 SAST
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 27, 01:00 SAST
Scheduled - EFT Secure will undergo scheduled maintenance on the 27th of March 2024, from 01:00AM to 05:00AM SAST. Downtime is anticipated between the specified time.

Please reach out to support@peachpayments.com with any questions or concerns.

Mar 22, 08:37 SAST
Mar 26, 2024

No incidents reported.

Mar 25, 2024
Resolved - This has been resolved.

Capitec pay was only impacted between the following times: 10:39 and 10:42 as well as 10:57 and 10:59.

Please reach out to support@peachpayments.com with any questions or concerns.

Mar 25, 11:54 SAST
Investigating - Capitec is currently experiencing an issue causing some electronic payments to fail affecting Capitec Pay.

We will keep you updated as they progress.

Here is what we know so far

Impacted systems - Electronic Payments, including Capitec Pay
Total or Intermittent - Intermittent
Impact on the client - Some electronic payments are failing, Clients should be able to retry if it fails.

Please reach out to support@peachpayments.com with any questions or concerns

Mar 25, 11:32 SAST
Mar 24, 2024

No incidents reported.

Mar 23, 2024

No incidents reported.

Mar 22, 2024
Completed - The scheduled maintenance has been completed.
Mar 22, 22:00 SAST
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 22, 21:00 SAST
Scheduled - IS hosting site will be performing maintenance on the internal power grid at Bryanston site that may have an impact on the Scan to Pay services.

Customers may not be able to transact if the Scan to Pay service goes down at any point during this maintenance period.

Please reach out to support@peachpayments.com with any questions or concerns.

Mar 20, 08:04 SAST
Resolved - Capitec Pay has been restored. The Capitec team are still further investigating what the issue was and how to prevent it going forward.

Please reach out to support@peachpayments.com with any questions or concerns

Mar 22, 19:55 SAST
Update - We are continuing to investigate this issue.
Mar 22, 18:31 SAST
Investigating - Please note that all Capitec Pay transactions are failing at the moment. They are failing with 900.100.100 (unexpected communication error with connector/acquirer).

The Capitec team are investigating and we will provide any updates from them as soon as received.

Please reach out to support@peachpayments.com with any questions or concerns.

Mar 22, 18:30 SAST
Resolved - This incident has been resolved.
Mar 22, 08:36 SAST
Investigating - The Capitec banking app and online banking platforms are experiencing technical issues.

The Capitec team are working on resolving this. Apologies for any inconveniences caused.

If you have any questions or concerns please reach out to support@peachpayments.com

Mar 19, 13:50 SAST
Mar 21, 2024

No incidents reported.

Mar 20, 2024
Completed - The scheduled maintenance has been completed.
Mar 20, 05:00 SAST
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 20, 01:00 SAST
Scheduled - Please note that the 1Voucher team has planned maintenance that may affect their systems. We will have schedule downtime [20 March 2024, [01:00 - 05:00 ].

During this time, you may experience intermittent downtime.

Please reach out to support@peachpayments.com with any questions or concerns

Mar 15, 12:21 SAST
Mar 19, 2024
Mar 18, 2024

No incidents reported.

Mar 17, 2024
Completed - The scheduled maintenance has been completed.
Mar 17, 02:00 SAST
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 17, 01:00 SAST
Scheduled - Capitec Pay will be conducting planned maintenance. We expect some downtime on the 17th of March from 01:00 am – 02:00 am.

Here is what we know:
Impacted systems - All Capitec Pay transactions will be affected.

Please reach out to support@peachpayments.com with any questions or concerns

Mar 15, 14:10 SAST
Mar 16, 2024
Resolved - This incident has been resolved.
Mar 16, 07:34 SAST
Update - We continue to monitor as we see a recovery of services in most instances
Mar 14, 20:15 SAST
Monitoring - Capitec Pay transactions are seeing recovering conversion rates.

We will continue to monitor and provide further updates.

Please reach out to support@peachpayments.com for any questions or concerns.

Mar 14, 16:21 SAST
Identified - Submarine cables Wacs and SAT3 are down. This is affecting multiple countries using these cable systems. Providers are trying to reroute as much traffic as possible but this is also causing congestion on the cables where traffic has been routed across.

Efforts to resolve are continuing. We will post any further updates here.

Please reach out to support@peachpayments.com with any questions or concerns.

Mar 14, 14:16 SAST
Investigating - Please note that due to a Global issue with Microsoft Azure being down, Capitec Pay transactions have been affected.

Customers might be unable to authenticate transactions.

Please reach out to support@peachpayments.com with any questions or concerns.

Mar 14, 14:10 SAST
Resolved - The residual impact of this event has been remedied by acquirers and processing has been restored to normal
Mar 16, 07:32 SAST
Update - We continue to monitor. We have seen recovery in most areas.
Mar 14, 20:16 SAST
Identified - Submarine cables Wacs and SAT3 are down. This is affecting multiple countries using these cable systems. Providers are trying to reroute as much traffic as possible but this is also causing congestion on the cables where traffic has been routed across.

Efforts to resolve are continuing. We will post any further updates here.

Please reach out to support@peachpayments.com with any questions or concerns.

Mar 14, 14:16 SAST
Investigating - Please note that due to a Global issue with Microsoft Azure since 1pm , we are seeing failures across multiple banks.

Currently, we have confirmed with FNB, ABSA, Nedbank, Standard Bank and Investec that this is affecting processing for them.

We are also seeing issues on Discovery - awaiting confirmation.

This is affecting both acquiring and issuing services.

FNB has advised that their systems are back up and we should start seeing an improvement there.

Please reach out to support@peachpayments.com with any questions or concerns.

Mar 14, 14:10 SAST
Mar 15, 2024

No incidents reported.

Mar 14, 2024
Completed - The scheduled maintenance has been completed.
Mar 14, 01:30 SAST
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 14, 01:00 SAST
Scheduled - Capitec will be conducting emergency maintenance on their payment services. We expect some downtime on the 14th of March from 01:00 am – 01:30 am.

Here is what we know:
Impacted systems - All Capitec Pay transactions will be affected.
Impact on the client – Capitec Pay payments will fail

Please reach out to support@peachpayments.com with any questions or concerns

Mar 13, 17:25 SAST