Absa intermitted performance
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted May 11, 2022 - 07:07 SAST
Investigating
We have raised an incident with Absa and we have received confirmation there is a Bankserv incident.
Posted May 10, 2022 - 13:14 SAST
This incident affected: Third-party Platforms (Issuing systems for Card processing).