Absa unavailable intermittently
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Nov 27, 2021 - 12:34 SAST
Investigating
We're experiencing an elevated number of transactions being unsuccessful to Absa cardholders. This will result in transactions for Absa holder to be unsuccessful during this period.

This has been escalated to Absa and we await their investigation response
Posted Nov 27, 2021 - 11:42 SAST
This incident affected: Third-party Platforms (Issuing systems for Card processing).