Capitec Pay – Service Disruption

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Jul 14, 2026 - 20:22 SAST

Investigating

We are currently investigating an issue affecting Capitec Pay transactions. Our team has identified the issue and has engaged Capitec Pay to investigate and work towards a resolution.

We apologise for any inconvenience this may cause and will continue to provide updates on this status page as more information becomes available.

If you have any questions or concerns, please contact support@peachpayments.com or reach out to your Account Manager.
Posted Jul 14, 2026 - 15:38 SAST
This incident affected: Third-party Platforms (Capitec Pay).