CapitecPay Transaction Failures
Incident Report for Peach Payments
Resolved
Following our monitoring, we can confirm that now, the issue is resolved. Thank you.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Jun 11, 2024 - 08:15 SAST
Monitoring
The fix has been implemented and we are now seeing recovery - Capitec Pay transactions are going through successfully. Both Peach Payments Team and Capitec Team are on standby and we are performing all required checks, along with transaction monitoring.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Jun 11, 2024 - 07:10 SAST
Update
We have been informed by Capitec Team that the fix is still running - There is a high incident logged with AWS who are actively looking into getting the affected environment back to working order.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Jun 11, 2024 - 06:38 SAST
Update
The Capitec Team informed that they are still working on the deployment for the fix - the run through is taking longer than expected.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Jun 11, 2024 - 05:12 SAST
Identified
The issue has been identified and a fix is currently being applied by Capitec Team. Services will be disrupted for a while - We apologise for the inconveniences caused.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Jun 11, 2024 - 04:11 SAST
Investigating
We have noted a spike in declines for Capitec Pay transactions. We are currently investigating and working closing with the Capitec Team to resolve the issue - we will provide updates as they become available.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Jun 11, 2024 - 03:23 SAST
This incident affected: Plugins and Platforms (Magento, WooCommerce, Shopify, Payment API, Wix, Payment Links), Checkout, and Third-party Platforms (Capitec Pay).