Capitec App - authentication - investigating

Incident Report for Peach Payments

Resolved

The Capitec team has confirmed the issue has been resolved.

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Aug 23, 2024 - 21:42 SAST

Update

We are continuing to investigate this issue.
Posted Aug 23, 2024 - 18:12 SAST

Investigating

Capitec App - Severity 1 – App Issues -
This is affecting authentication of transactions within the Capitec App

Capitec App is currently experiencing issues with the App. Their team is investigating, and we will keep you updated as we progress.
Affected services:
Capitec Pay
Capitec Cards

Our sincerest apologies for any inconvenience caused.
If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Aug 23, 2024 - 18:07 SAST
This incident affected: Third-party Platforms (Capitec Pay, Issuing systems for Card processing).