Instore - POS unexpected reversals

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 13:14 SAST

Monitoring

Our Engineers have restored the service to normal operating now
We're doing a root cause at the moment and will share with affected merchants.

We will continue to monitor.

We apologise for any inconvenience caused and will continue to update this status page as we make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Apr 14, 2025 - 12:03 SAST

Investigating

We are seeing unexpected reversals at some of our in-store merchants and are investigating.

This is a service interruption on instore.

We apologise for any inconvenience caused and will continue to update this status page as we make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Apr 14, 2025 - 11:59 SAST
This incident affected: In-store card processing (In-store card processing - Absa Card Present).