Service degradation: Increased latency on Dashboard, Checkout and Payments API
Incident Report for Peach Payments
Resolved
The degraded performance has been resolved and no transactions were affected.

We apologise for any inconvenience caused and thank you for your patience while our team worked on the issue. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Sep 05, 2024 - 17:32 SAST
Identified
Our Engineers have identified the root cause and fix is being implemented.
Posted Sep 05, 2024 - 17:28 SAST
Investigating
Dashboard, Checkout and Payments API is currently experiencing degraded performance in updating transactions.

Our team of Engineers are investigating and working to resolve it as soon as possible.
No transactions are being affected.

We apologise for any inconvenience caused and will continue to update this status page as we make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Sep 05, 2024 - 17:16 SAST
This incident affected: Plugins and Platforms (Magento, WooCommerce, Shopify, Payment API, Wix) and Checkout.