Peach Payments Support Phone line intermitted
Incident Report for Peach Payments
Resolved
We can confirm all calls are reaching our Peach support team and it seems there was a lag issue with the VOIP service which has been resolved.
Posted May 17, 2022 - 13:54 SAST
Investigating
We have raised a support ticket with our VOIP provider.
We are seeing intermitted call performance.
Please may you log a support ticket with your request until this has been resolved.
Posted May 17, 2022 - 11:56 SAST
This incident affected: Support (Phone Support).