Instant EFT by Peach Payments intermittent performance
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Feb 23, 2023 - 03:28 SAST
Update
We are continuing to investigate this issue.
Posted Feb 22, 2023 - 18:48 SAST
Investigating
We are investigating the potential issue that may be causing any impact on our clients. We are working to identify the scope of impact and implement a solution as quickly as possible.

This incident affects: 🏦 Absa (Account Linking), 🏦 Capitec (Account Linking), 🏦 FNB (Account Linking), 🏦 Nedbank (Account Linking), 🏦 Standard Bank (Account Linking)
Posted Feb 22, 2023 - 17:59 SAST
This incident affected: Third-party Platforms (Instant EFT by Peach Payments).