Capitec Pay transactions unsuccessful

Incident Report for Peach Payments

Monitoring

Capitec have advised that this incident is resolved, we are currently monitoring.
Posted Aug 28, 2026 - 05:53 SAST

Investigating

We are experiencing a high number of transactions being unsuccessful for Capitec Pay.
We have escalated to Capitec for investigation and will update accordingly as we receive further information.
Posted Aug 28, 2026 - 04:35 SAST
This incident affects: Third-party Platforms (Capitec Pay).