Elevated Declines for Visa - FNB transactions

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Aug 19, 2026 - 13:29 SAST

Update

Transaction processing for VISA BIN on FNB issuing has stabilised.
Posted Aug 19, 2026 - 12:27 SAST

Monitoring

FNB has identified the root cause and we are observing a recovery. Monitoring is in place.
Posted Aug 19, 2026 - 11:59 SAST

Investigating

Our acquiring partners have observed declined transactions with response 59 on VISA BINs for FNB issuing. Our partners are engaging with FNB regarding the observed impact.

We will continue to update this status page as the partner make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Aug 19, 2026 - 11:10 SAST
This incident affected: Third-party Platforms (FNB card acquiring).