The issue has been resolved. Merchants' customer can now pay using M- Pesa Services.
We apologise for any inconvenience caused and thank you for your patience while our team worked on the issue. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Jul 06, 2026 - 17:17 SAST
Investigating
We are currently experiencing degraded performance affecting M-Pesa services. Our team has identified the issue and has engaged M-Pesa to investigate and work towards a resolution.
We apologise for any inconvenience this may cause and will continue to provide updates on this status page as more information becomes available.
If you have any questions or concerns, please contact support@peachpayments.com or reach out to your Account Manager.
Posted Jul 06, 2026 - 10:40 SAST
This incident affected: Third-party Platforms (MPESA).