Capitec intermittent downtime
Incident Report for Peach Payments
Resolved
This has been resolved.

Capitec pay was only impacted between the following times: 10:39 and 10:42 as well as 10:57 and 10:59.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Mar 25, 2024 - 11:54 SAST
Investigating
Capitec is currently experiencing an issue causing some electronic payments to fail affecting Capitec Pay.

We will keep you updated as they progress.

Here is what we know so far

Impacted systems - Electronic Payments, including Capitec Pay
Total or Intermittent - Intermittent
Impact on the client - Some electronic payments are failing, Clients should be able to retry if it fails.

Please reach out to support@peachpayments.com with any questions or concerns
Posted Mar 25, 2024 - 11:32 SAST
This incident affected: Peach card processing platform and Third-party Platforms (Capitec Pay).