RCS degraded performance

Incident Report for Peach Payments

Identified

The issue has been identified, a fix is in progress and our partner will potentially deployed it in Production tonight.

We apologise for any inconvenience caused and will continue to update this status page as we make progress.

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Oct 13, 2025 - 15:05 SAST

Investigating

We are currently experiencing an issue with our downstream partner RCS whereby transactions are failing with response Invalid Card. Our team is investigating the issue with them and actively working to resolve it as soon as possible.

We apologise for any inconvenience caused and will continue to update this status page as we make progress.

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Oct 13, 2025 - 10:56 SAST
This incident affects: Third-party Platforms (RCS).