MCB Juice degraded performance

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Sep 13, 2026 - 01:03 SAST

Update

MCB Juice, MCB JuicePro et Internet Banking seront hors ligne le dimanche 13 septembre de 00:00 à 03:00.
Posted Sep 13, 2026 - 00:03 SAST

Identified

MCB juice are under maintenance until 1am SAST
This is a planned maintenance window
Posted Sep 12, 2026 - 23:59 SAST

Investigating

We have escalated to partner for MCB juice transaction rejecting.
Posted Sep 12, 2026 - 23:52 SAST
This incident affected: Third-party Platforms (MCB Bank Mauritius).