Samsung Pay - intermittent performance

Incident Report for Peach Payments

Update

Our team is investigating an issue affecting Samsung Pay and is working to resolve it as soon as possible. This will affect merchants processing transactions.
Customers are not able to see Samsung Pay sandbox and live checkout

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Mar 16, 2026 - 17:41 SAST

Update

We are continuing to investigate this issue.
Posted Mar 16, 2026 - 17:41 SAST

Investigating

Our team is investigating an issue affecting Samsung Pay and is working to resolve it as soon as possible. This will affect merchants processing transactions.
Samsung Pay sandbox and live checkout

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Mar 16, 2026 - 17:39 SAST
This incident affects: Checkout.