Nedbank User Authentication - intermitted performance
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Jul 30, 2022 - 15:18 SAST
Investigating
Nedbank confirmed of an issue with authentication on Nedbank-issued cards. Since 9 am.
A Nedbank team have logged a severity 1 incident process and is underway.
Nedbank are working on resolving this.
Posted Jul 29, 2022 - 11:20 SAST
This incident affected: Third-party Platforms (Issuing systems for Card processing).