Intermittent Transaction Failure - M-Pesa
Incident Report for Peach Payments
Resolved
Following the latest intervention from the Peach team together with the MPESA provider team, this issue is now resolved.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Jun 26, 2024 - 19:44 SAST
Identified
The issue is still persisting due to the bad internet connectivity. The team is still working to resolve same.
Posted Jun 26, 2024 - 07:15 SAST
Update
We are continuing to investigate the issue with our providers - As at now, it seems that the intermittent disconnection is due to network failure on the partner's side.
Posted Jun 25, 2024 - 20:59 SAST
Investigating
Peach Payments team has been alerted on transactions failing for M-PESA. The engineers are working with the provider in order to investigate on the failures. Updates will be provided accordingly.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Jun 25, 2024 - 19:08 SAST
This incident affected: Checkout and Third-party Platforms (MPESA).