MSDK Update version - decommission of 3-D Secure V1 (3DS1)
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Oct 07, 2022 - 17:26 SAST
Investigating
At Peach Payments, we strive to continuously provide world-class, leading payments infrastructure that offers a secure and seamless experience for our merchants and their customers.

We have sent out communications around updating our MSDK version as we noted you are using an outdated version.
The request to update the version is due to new mandates from Visa and Mastercard and are related to 3DS 2.0 requirements.

Failure to update will result in failed transactions and not being able to process any card transactions.

One of the major initiatives that we are currently undertaking is switching over our merchants to the 3D Secure 2 standard, as part of a global roll-out. To find out more about 3DS 2 and why switching to this standard will add considerable value to your business, please have a look at this support page we have put together for you: https://peachpayments.freshdesk.com/support/solutions/articles/47001198732

Important: The decommission of 3-D Secure V1 (3DS1) has started. Visa, Mastercard, American Express, JCB, Diners/Discover, Mada and Carte Bancaire have scheduled to decommission 3DS1 globally in October 2022. Customers are strongly recommended to implement 3-D Secure V2 if they have not already done so to ensure compliance with these requirements. Transactions that do not meet strong customer authentication (SCA) requirements will experience declines after this date.
Depending on your integration, the mobile SDK supports 3-D Secure V2:
Ready-to-Use UI:
o from version 3.4.0 with browser-based authentication (a setting in Business Intelligence Platform is required)
o from version 4.0.0 with fully-supported features
Custom & Your Own UI: from version 4.0.0
We strongly recommend updating the mobile SDK to the latest version and reviewing our 3-D Secure V2 documentation for more information.
https://peachpayments.docs.oppwa.com/tutorials/mobile-sdk/emv-3ds

It can be downloaded here: https://peachpayments.docs.oppwa.com/tutorials/mobile-sdk/download

username : test@merchantname.com
password : merchantname1234

You must ensure you are using the latest version of the Mobile SDK, and then make the required changes as outlined in the technical documentation that can be seen at: https://peachpayments.docs.oppwa.com/tutorials/mobile-sdk/emv-3ds
Let us know if you have any questions and the team will assist.

Please do reach out to your Peach Payments Account Manager, or email us at support@peachpayments.com should you have any queries about this.

We look forward to Peach Payments continuing to work hand-in-hand with your business, continuing our journey of growth.

Thank you!
The Peach Payments Support Team
Posted Oct 07, 2022 - 17:26 SAST
This incident affected: Peach Payments Plugin or API Update Notifications (MSDK Updates).