Standard Bank Intermitted performance
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Aug 02, 2022 - 08:58 SAST
Investigating
We are currently investigating this issue.
Posted Aug 01, 2022 - 22:55 SAST
This incident affected: Third-party Platforms (Issuing systems for Card processing).