Intermittent performance - payment processing
Incident Report for Peach Payments
Resolved
Please note, that a fix has been implemented and this issue has now been resolved. Thank you for your patience and understanding.

If you have any questions, please contact us via support@peachpayments.com or reach out to your account manager.
Posted May 20, 2024 - 23:25 SAST
Investigating
Regrettably, the issue persists despite the fix implemented. Our team is currently formulating the next course of action and will promptly share the details with you. Thank you for your patience.

If you have any questions, please contact us via support@peachpayments.com or reach out to your account manager.
Posted May 20, 2024 - 20:07 SAST
Identified
Please note, that the issue has been identified and a fix is currently in progress.

This should take approximately 30 minutes to complete. We will provide another update shortly.

If you have any questions, please contact us via support@peachpayments.com or reach out to your account manager.
Posted May 20, 2024 - 19:23 SAST
Update
We are continuing to investigate this issue.
Posted May 20, 2024 - 18:25 SAST
Investigating
Our teams are mobilizing and initiating an investigation into the issue. We will provide additional information as soon as it becomes available. Thank you for your patience and understanding.

Investigating — May 20, 2024 05:53 PM South Africa Standard Time -The Peach Payments teams are presently in the process of triaging the issue.
Customers may encounter HTTP response errors, which include but are not limited to 200.300.404 and 200.300.406

If you have any questions, please contact us via support@peachpayments.com or reach out to your account manager.
Posted May 20, 2024 - 18:24 SAST
This incident affected: Peach card processing platform and Third-party Platforms (Absa card acquiring, ApplePay, FNB card acquiring, I&M Bank Acquiring - Kenya, Nedbank card acquiring, MCB Bank Mauritius, Peach card acquiring, Planet Payments Multi Currency Payments).