Microsoft downtime affecting Capitec Pay
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Mar 16, 2024 - 07:34 SAST
Update
We continue to monitor as we see a recovery of services in most instances
Posted Mar 14, 2024 - 20:15 SAST
Monitoring
Capitec Pay transactions are seeing recovering conversion rates.

We will continue to monitor and provide further updates.

Please reach out to support@peachpayments.com for any questions or concerns.
Posted Mar 14, 2024 - 16:21 SAST
Identified
Submarine cables Wacs and SAT3 are down. This is affecting multiple countries using these cable systems. Providers are trying to reroute as much traffic as possible but this is also causing congestion on the cables where traffic has been routed across.

Efforts to resolve are continuing. We will post any further updates here.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Mar 14, 2024 - 14:16 SAST
Investigating
Please note that due to a Global issue with Microsoft Azure being down, Capitec Pay transactions have been affected.

Customers might be unable to authenticate transactions.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Mar 14, 2024 - 14:10 SAST
This incident affected: Third-party Platforms (Capitec Pay).