1Voucher: intermittent downtime

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Mar 08, 2024 - 08:35 SAST

Investigating

Please note 1Voucher are currently experiencing issues causing intermittent timeouts.

The tech team are busy resolving the issue. We will provide further updates once resolved.

Please reach out to support@peachpayments.com with any questions or concerns
Posted Mar 07, 2024 - 18:47 SAST
This incident affected: Third-party Platforms (1Voucher).