MCB Juice Downtime

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Apr 12, 2025 - 12:03 SAST

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 12, 2025 - 11:26 SAST

Investigating

Please note we are currently seeing intermittent downtime with MCB Juice transactions. The team is investigating, and we will keep you updated as they progress.

We apologise for any inconvenience caused and will continue to update this status page as we make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Apr 12, 2025 - 11:22 SAST
This incident affected: Third-party Platforms (MCB Bank Mauritius).