Degraded performance for Peach Services
Incident Report for Peach Payments
Resolved
This incident has been resolved - Transactions are now synchronised and are appearing correctly on the Dashboard. The Peach Engineers are actively monitoring the situation.

We apologise for any inconvenience caused. Thank you.
Posted Sep 04, 2024 - 17:10 SAST
Monitoring
We can confirm that the services are restored for payment links and payment pages.

Transactions will be delayed in appearing on the Dashboard - our engineers are working to restore the dashboard services. The estimated completion time will be around 14:00 to 16:30 SAST.
Posted Sep 04, 2024 - 12:12 SAST
Investigating
Payment Links and Payment Page are currently experiencing degraded performance resulting in merchants' customers not being able to pay using these products.

Our team is investigating the issue and working to resolve it as soon as possible.

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Sep 04, 2024 - 11:56 SAST
This incident affected: Support (Console, Dashboard - Peach Payments), Peach card processing platform, Checkout, and Plugins and Platforms (Payment Links).