Absa digital banking unavailable

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Sep 08, 2021 - 08:39 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 08, 2021 - 08:24 SAST

Investigating

Absa have confirmed that their digital banking systems are unavailable since approximately 6h30 this morning. As a result Absa card holders are unable to authenticate transactions online or via their App thus causing all transactions requiring authentication to "time out"
Absa are investigating
Posted Sep 08, 2021 - 08:01 SAST
This incident affected: Third-party Platforms (Issuing systems for Card processing).