Delay in transactions updating in the dashboard
Incident Report for Peach Payments
Resolved
all transactions have updated
Posted Jun 05, 2024 - 21:14 SAST
Identified
We are in the process of recovering, transactions are updating, we will continue to monitor until all transactions are reflecting.
Posted Jun 05, 2024 - 20:00 SAST
Investigating
We are currently experiencing a delay in updating transactions in the Peach Payments dashboard, our teams are actively monitoring and will keep you updated.
Posted Jun 05, 2024 - 19:18 SAST
This incident affected: Support (Console, Dashboard - Peach Payments).