Intermittent performance - degraded performance - Visa and Mastercard - BankServ

Incident Report for Peach Payments

Resolved

Bankserv Stability Update/Recovered Recovery noted on CNP Acquirer and ECI5
No further updates.

We apologise for any inconvenience caused and will continue to update this status page as we make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Apr 12, 2025 - 14:48 SAST

Update

Bankserv Stability Update

▪️Bankserv observing intermittent upstream challenges to both Master Card and Visa.
▪️P1 support calls raised with both service providers for further investigations.
Posted Apr 12, 2025 - 12:30 SAST

Investigating

We have been informed by BankservAfrica that MasterCard are currently experiencing challenges impacting eCommerce and related services.
This may be seen both 3DSecure and non3Dsecure

We will keep a close eye on the environment until stability has been established.

We apologise for any inconvenience caused and will continue to update this status page as we make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Apr 12, 2025 - 11:47 SAST
This incident affected: Third-party Platforms (Issuing systems for Card processing).