Tymebank is currently offline

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Oct 29, 2022 - 13:33 SAST

Monitoring

Tymebank card transactions are rejecting as they are currently offline. We are monitoring and will update once we observe a change.
Posted Oct 29, 2022 - 12:51 SAST
This incident affected: Third-party Platforms (Issuing systems for Card processing).