Althec Connector for FNB merchants
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Oct 13, 2022 - 17:32 SAST
Investigating
We are currently investigating this issue.
Posted Oct 13, 2022 - 16:31 SAST
This incident affected: Third-party Platforms (FNB card acquiring).