Mpesa Intermittent Perfomance

Incident Report for Peach Payments

Resolved

MPESA Performance Resolved: The intermittent performance issues previously affecting MPESA servers appear to be resolved.

If you have any questions, please contact support@peachpayments.com or your Peach Payments account manager.
Posted Apr 09, 2025 - 21:03 SAST

Investigating

We are currently seeing intermittent performance of Mpesa servers.
We have reached out to Mpesa.

For any queries, please reach out to us via support@peachpayments.com or your Peach Payments account manager to have this exciting new payment method enabled on your account.
Posted Apr 09, 2025 - 20:31 SAST
This incident affected: Third-party Platforms (MPESA).