Intermittent transaction failures experienced on card payments

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted May 24, 2026 - 23:59 SAST

Monitoring

We have seen a notable improvement and continue to monitor.
Posted May 24, 2026 - 23:48 SAST

Investigating

We are seeing higher than usual transaction failures on card processing - our teams are currently investigating
Posted May 24, 2026 - 22:46 SAST
This incident affected: Peach card processing platform.