We apologise for any inconvenience caused and thank you for your patience while the standard bank team worked on the issue. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Jul 15, 2025 - 10:04 SAST
Monitoring
We can note that transactions are processing normally with Standard bank issued cards. We are currently monitoring and will continue to update this status page as we make progress.
Posted Jul 15, 2025 - 06:37 SAST
Investigating
Standard bank is currently experiencing degraded performance resulting in merchants' customers not being able to pay using Standard bank issued cards. Our team is investigating the issue with Standard bank team and will advise further.
We apologise for any inconvenience caused and will continue to update this status page as we make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Jul 15, 2025 - 02:15 SAST
This incident affected: Peach card processing platform and Third-party Platforms (Absa card acquiring, Nedbank card acquiring).