Degraded performance on Mastercard

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Aug 15, 2026 - 08:23 SAST

Monitoring

We are observing recovery on MasterCard transactions. We will keep on monitoring and update the status page accordingly.
Posted Aug 15, 2026 - 08:04 SAST

Investigating

Please note that MasterCard is globally down and experiencing degraded performance. We have logged a case with the partner for investigation.

We will continue to update this status page as we observed progress with MasterCard. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Aug 15, 2026 - 07:55 SAST
This incident affected: Peach card processing platform.