Our engineer confirmed that the issue is now resolved. We apologise for the inconvenience caused and remain available on support@peachpayments.com, should you require any further assistance.
Posted Oct 03, 2024 - 10:45 SAST
Identified
The issue has been identified and the team is working on a solution to resolve it.
Posted Sep 19, 2024 - 15:54 SAST
Investigating
We are currently investigating an issue where merchants cannot refund Mobicred transactions. Our team is investigating the issue and working to resolve it as soon as possible. All relevant parties have been contacted.
We apologies for any inconvenience caused and will continue to update this status page as we make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Sep 18, 2024 - 14:24 SAST
This incident affected: Third-party Platforms (Mobicred).