Intermittent Capitec App issues
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted May 13, 2024 - 13:32 SAST
Investigating
Please note we have noted a drop in conversion rate on Capitec Pay.

This is due to an intermittent issue affecting iOS clients who make use of the Capitec App. The team is busy working on a fix that they plan on deploying later this evening.

Update: the fix did not have the desired affect and this issue is still ongoing. We will provide further updates as they become available.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted May 08, 2024 - 16:10 SAST
This incident affected: Third-party Platforms (Capitec Pay).