Ecwid: Errors on Checkout initiation
Incident Report for Peach Payments
Resolved
Please note the issue has been identified and resolved.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Apr 19, 2024 - 14:26 SAST
Investigating
Please note, currently our checkout initiation on Ecwid is erroring.

Our team is investigating and we will provide updates as they become available.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Apr 19, 2024 - 10:13 SAST